Réglage X11 (Xfree86).

Le serveur X pour les tampons de trame (NDT: c'est à dire frame buffers) (le paquetage Debian "xserver-fbdev") fonctionne bien avec le XF86config installé par défaut.

Mon clavier est un AZERTY français, et j'ai quelques problèmes. Le fichier de map "mac-fr3" est bon sous la console.


Note spécifiques à Debian : L'installateur Debian a refusé de changer le fichier de map (menu "Configuring the keyboard"), avec comme excuse "This is not a valid binary keymap".

Pas encore résolu : sous X11, je n'ai pas encore tous les caractères. Il me manque le |, par exemple, même si tout va bien sous la console.

Au démarrage, le serveur X annonce :

XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
...
Operating System: Linux 2.3.10 ppc [ELF]
Configured drivers:
   FBDev: Server for frame buffer device
   (Patchlevel 11): mfb, afb, cfb8, cfb16, cfb32, NCR 77C32BLT (accel), ATI Mach64 (accel), IMS TwinTurbo (accel), 3Dlabs Permedia 2 (accel)
(using VT number 7)
XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: disabled
(**) Mouse: type: BusMouse, device: /dev/mouse, buttons: 3
(**) FBDev: Graphics device ID: "Linux Frame Buffer Device"
(**) FBDev: Monitor ID: "Generic Monitor"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) FBDev: Using default frame buffer video mode
(--) FBDev: Frame buffer device: platinum
(--) FBDev: Video memory: 1024K @ 0xf1000090
(--) FBDev: MMIO regs: 4K @ 0xf8000000
(--) FBDev: Type 0 type_aux 0 bits_per_pixel 8
(--) FBDev: Hardware accelerator: None
(--) FBDev: No driver support for hardware acceleration
bpp = 8, depth = 8, BitsPerRGB = 8
(--) FBDev: Using cfb8 driver


retour