[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gulliver] downgrader certains packages debian en tenant compte des dépendances


From Olivier Dameron <olivier dot dameron at neuf dot fr>
Subject Re: [gulliver] downgrader certains packages debian en tenant compte des dépendances
Date Sun, 22 Oct 2006 10:35:26 +0200

Bonjour David,

On Sat, 21 Oct 2006 22:01:28 +0200
David MENTRE <dmentre at linux-france dot org> wrote:

> Je ne sais pas si c'est plus élégant, mais lors de la mise à jour
> vérolée du server X sur Ubuntu Dapper, j'ai découvert qu'on pouvait
> demander une version de paquet à une version spécifique, par
> exemple : 
> 
>   sudo apt-get install xserver-xorg-core=1:1.0.2-0ubuntu10

oui.
Mais est-ce que ça va aussi me downgrader les packages dont kpilot dépend ?

Pour savoir, le meilleur moyen c'est encore d'essayer.
Si je regarde dans les archives, je trouve ça:
olivier at ravenclaw ~> ll /var/cache/apt/archives/kpilot_4%3a3.5.*
-rw-r--r-- 1 root root 1947292 Jul 17 19:32 /var/cache/apt/archives/kpilot_4%3a3.5.3-3_i386.deb
-rw-r--r-- 1 root root 1948164 Sep 25 23:48 /var/cache/apt/archives/kpilot_4%3a3.5.4-1+b1_i386.deb
-rw-r--r-- 1 root root 1955192 Aug 26 23:47 /var/cache/apt/archives/kpilot_4%3a3.5.4-1_i386.deb
-rw-r--r-- 1 root root 1950078 Oct  8 00:34 /var/cache/apt/archives/kpilot_4%3a3.5.5-1_i386.deb

Mais:
olivier at ravenclaw ~> sudo apt-get -s install kpilot=3.5.3-3
Reading package lists... Done
Building dependency tree... Done
E: Version '3.5.3-3' for 'kpilot' was not found

olivier at ravenclaw ~> sudo apt-get -s install kpilot=4:3.5.3-3
Reading package lists... Done
Building dependency tree... Done
E: Version '4:3.5.3-3' for 'kpilot' was not found

olivier at ravenclaw ~> sudo apt-get -s install kpilot=4:3.5.3  
Reading package lists... Done
Building dependency tree... Done
E: Version '4:3.5.3' for 'kpilot' was not found

Rigolo, non ?
olivier