[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gulliver] livebox en ethernet


From Michael <michael dot henneton at wanadoo dot fr>
Subject Re: [gulliver] livebox en ethernet
Date Fri, 09 Feb 2007 13:42:34 +0100

oula je crois qu'il y a du cafouillage... ou  alors c'est moi qui ne comprends pas tout

tu n'a pas besoin de pppoeconf , il  te suffit juste de de faire un
dhclient 'nom de ton interface'

ou si tu veux t'eviter de taper cette commande a chaque demmarage,
si tu es sur une debian* ou approchant , tu edites (en root ) ton fichier

/etc/network/interfaces et si ton interface s'appelle par exemple eth0 tu ajoutes cette entrée :

#auto eth0   <--a decommenter ou non si tu veux monter ton interface a chaque demarrage automatiquement
iface eth0 inet dhcp  <-- pour indiquer que tu es en dhcp

 et tu sauvegardes

puis tu fais un 'ifdown eth0' puis un 'ifup eth0'
 puis apres un ifconfig , tu verras si tu recupere bien une IP, une gateway

a ce stade tu devrais pouvoir pinguer ta livebox en 192.168.1.1 mais pas pinguer encore ta livebox
car il te manque alors ton parametrage dns, pour cela vas dans /etc/resolv.conf et ajoutes cette ligne :

nameserver    192.168.1.1

et la tente un ping google.fr , ca devrait fonctionner.


(*)PS: si tu es sous freebsd par exemple la c'est dans /etc/rc.conf

tu ajoutes/modifie
defaultrouter 192.168.1.1 #pour avoir une route par defaut et le dns configuré dans ton cas
ifconfig_'nom_interface'="DHCP" #attention de ne pas oublier le _ entre ifconfig et  'nominterface'
hostname="nom_machine";

puis tu fais un dhclient nom_interface




alex5027 at tiscali dot fr a écrit :
Bonjour,
Je n'arrive pas a etablir une connexion internet avec une
livebox inventel en ethernet. Je precise d'abord que deux
autres PC y ont acces en continu par le wifi.
J'ai bien brancher la livebox a ma carte reseau. Un ifconfig
reconnait bien ma eth0, et lui voit meme un masque de
sous-reseau 255.255.255.0 (de memoire).
Quand je ping l'adresse 192.168.1.1 ca foire, par contre
j'arrive a atteindre la 192.168.1.9 qui correspond au debut
de la plage DHCP. Je suis aller voir sur wikipedia et je
crois que cela signifie que la livebox a bien adressé une IP
a mon ordi. Pendant la commande pppoeconf 192.168.1.1 j'ai
un joli "no such device" et je dois preciser qu'on me
demande les mots de passe internet (que je ne connais pas,
mais ca devrai pas m'empecher de pinger la livebox, non ? ).
Voilà, je m'en retourne a vous,
Alex

--------------------- ALICE SECURITE ENFANTS ---------------------
Protégez vos enfants des dangers d'Internet en installant Sécurité Enfants, le contrôle parental d'Alice.
http://www.aliceadsl.fr/securitepc/default_copa.asp




---- Liste gulliver ----
Archives,    http://gulliver.eu.org/ml-archives/
Description, http://gulliver.eu.org/ml/ml.html
Bons usages, http://gulliver.eu.org/wiki/UsagesCourriels