[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gulliver] Config PPPOE-Ethernet-Sagem


From Philippe Revault <phrevault at tele2 dot fr>
Subject Re: [gulliver] Config PPPOE-Ethernet-Sagem
Date Thu, 08 Feb 2007 11:13:25 +0100

Philippe Revault wrote:

>Frederic Lehobey wrote:
>
>  
>
>>Salut,
>>
>>On Tue, Jan 16, 2007 at 08:23:13PM +0100, Philippe Revault wrote:
>> 
>>
>>    
>>
>>>gaulier_jp at yahoo dot fr wrote:
>>>
>>>   
>>>
>>>      
>>>
>>>>sudo -s
>>>>echo "mii-tool -A 10baseT" >> /etc/init.d/networking
>>>>
>>>>
>>>>devrait suffire mais n'est pas très propre.
>>>>
>>>>(cf fonctionnement init.d et startstop daemon).
>>>>     
>>>>
>>>>        
>>>>
>> 
>>
>>    
>>
>>>après reboot j'obtiens :
>>>
>>>debian:/home/ren# mii-tool
>>>eth0: negotiated 100baseTx-HD, link ok
>>>
>>>debian:/home/ren# mii-tool -A 10baseT
>>>restarting autonegotiation...
>>>debian:/home/ren# mii-tool
>>>eth0: negotiated 10baseT-HD, link ok
>>>
>>>Ce que je voudrais savoir en fait, c'est comment passer une
>>>configuration dans (ou avant) pppoe, compte-tenu que cela doit avoir
>>>lieu dans le pre-up de pppoe :
>>>   
>>>
>>>      
>>>
>> Et ajouter la commande ci-dessous ?
>>
>> 
>>
>>    
>>
>>>debian:/home/ren# cat /etc/network/interfaces
>>># This file describes the network interfaces available on your system
>>># and how to activate them. For more information, see interfaces(5).
>>>
>>># The loopback network interface
>>>auto lo
>>>iface lo inet loopback
>>>
>>>auto dsl-provider
>>>iface dsl-provider inet ppp
>>>    provider dsl-provider
>>>   
>>>
>>>      
>>>
>>      pre-up mii-tool -A 10baseT
>> 
>>
>>    
>>
>>># please do not modify the following line
>>>    pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
>>>   
>>>
>>>      
>>>
>>à moins que ce ne soit plutôt :
>>
>>      up mii-tool -A 10baseT
>>
>> « man interfaces » pour l'explication.
>>
>>   (pre-up pour avant, up pour après)
>>
>>Librement,
>>Frédéric
>>
>>
>>    
>>
>merci pour vos conseils, j'ai finalement choisi la solution de passer
>par un script (d'une seule ligne !) pour passer la commande au démarrage
>(/etc/init.d et update-rc.d) ; cela fonctionne de cette manière.
>
>Les commandes dans le fichier /etc/network/interfaces ne donnent pas de
>résultat.
>
>D'autre part je lis dans le README de pppoe :
>- The Debian pppoe program is patched to automatically bring up the
>  Ethernet interface.
>mais ne donne pas plus d'indication pour en assurer la configuration.
>
>donc en attendant de changer de modem, ça pourra aller comme ça.
>
>Merci à tous de vos conseils,
>a bientôt,
>PhR.
>
>  
>

Je reviens sur ce fil de discussion pour le couper plus proprement que je ne l'ai fait précédemment. Après avoir bossé sur le fichier de configuration du réseau comme me le conseillait Frédéric j'ai adopté les commandes suivantes :
  pre-up /sbin/ifconfig eth0 up  # line maintained by pppoeconf
  pre-up /sbin/ifconfig eth0 mtu 1460 # mtu négocié par pppd auprès de mon FAI
  up /sbin/mii-tool -A 10baseT-HD eth0 # le modem fonctionne à 8Mbps

et j'obtiens les résultats attendus par cette configuration, sans toutefois règler les problèmes de déconnexion du lien entre le modem et la carte ethernet. Au moins j'aurais appris quelquechose de la configuration de base du réseau  :-) 
PhR.