[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gulliver] [Suse 10.2] Plus de wifi..


From Salseros <brucot at free dot fr>
Subject Re: [gulliver] [Suse 10.2] Plus de wifi..
Date Sat, 23 Dec 2006 16:44:39 +0100

Bonjour à tous

Suite aux tentatives de faire fonctionner ma Wifi de hier soir à la
permanence de Gulliver, qui nous a amené à la conclusion qu'il est pas
possible dans l'état actuel des choses, de faire fonctionner ma carte
Broadcom BCM4306 802.11b/g, j'ai donc acheté une carte OvisLink
Evo-W54PCM (RaLink RT2500) chez TLCI, que j'ai pu essayé et Oh victoire
! qui a marché :-) , Gaëtan était présent dans le magasin, il peut
témoigner.
Cependant, eh ben chez moi ça ne marche toujours pas... :-(

Voilà le problème :
La carte Broadcom détecte tjs les réseaux sur eth1 et ma nouvelle carte
qui pointe sur wlan0, non.
 Voilà ce que donne le iwconfig et le ifconfig

adslert:/home/salserino # iwconfig
lo        no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:off/any  Nickname:"Broadcom 4306"
          Mode:Managed  Frequency=2.484 GHz  Access Point: Invalid
          Bit Rate=1 Mb/s   Tx-Power=15 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

wmaster0  IEEE 802.11g  Frequency:2.412 GHz
          RTS thr:off   Fragment thr=2346 B

wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          RTS thr:off   Fragment thr=2346 B
          Encryption key:off

sit0      no wireless extensions.


adslert:/home/salserino # ifconfig
eth0      Lien encap:Ethernet  HWaddr 00:0F:B0:4A:A6:B0
          adr inet6: fe80::20f:b0ff:fe4a:a6b0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1180 (1.1 Kb)  TX bytes:1152 (1.1 Kb)
          Interruption:185 Adresse de base:0xe800

eth1      Lien encap:Ethernet  HWaddr 00:90:4B:9F:A1:11
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:252 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:10584 (10.3 Kb)
          Interruption:11

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:484 errors:0 dropped:0 overruns:0 frame:0
          TX packets:484 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:36448 (35.5 Kb)  TX bytes:36448 (35.5 Kb)

wlan0     Lien encap:Ethernet  HWaddr 00:08:A1:96:6A:68
          UP RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 b)  TX bytes:108 (108.0 b)
          Adresse de base:0xc000

wmaster0  Lien encap:UNSPEC  HWaddr
00-08-A1-96-6A-68-00-C0-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Adresse de base:0xc000

adslert:/home/salserino # 

Pensant avoir une idée de génie, j'ai rebricolé mon script, de la
manière suivante, pensant que le problème était de faire pointer la
nouvelle carte sur eth1 :

/etc/init.d/network stop
rmmod bcm43xx
/sbin/modprobe rt2500pci
/usr/sbin/iwconfig eth1 key $KEY
/sbin/ifup-dhcp eth1

Mais, ça donne cela et ne marche pas :-(

Shutting down the NetworkManagererror updating device       done
Shutting down the DHCP DBUS Daemon                                    done
Shutting down the NetworkManagerDispatcher                            done
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device eth1 ; No such device.
interface eth1 is not available
adslert:/home/salserino #

le ifconfig :

adslert:/home/salserino # ifconfig
lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:652 errors:0 dropped:0 overruns:0 frame:0
          TX packets:652 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:48488 (47.3 Kb)  TX bytes:48488 (47.3 Kb)


et le iwconfig :

lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  IEEE 802.11g  Frequency:2.412 GHz
          RTS thr:off   Fragment thr=2346 B

wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          RTS thr:off   Fragment thr=2346 B
          Encryption key:off

sit0      no wireless extensions.


Et là je ne sais plus quoi faire. On mettant wlan0 dans mon script à la
place de eth1, ça change rien.