[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gulliver] JCT [j'aime pas java]


From Ludovic Danigo <ldng at free dot fr>
Subject Re: [gulliver] JCT [j'aime pas java]
Date Sun, 18 Dec 2005 15:11:32 +0100

Selon Rodolphe Quiedeville <rq at lolix dot org>:

> > Je viens de tester l'application avec ce VM et ça marche sans
> aucun problème.
> > $ java -version
> > java version "1.4.2-02"
> > Java(TM) 2 Runtime Environment, Standard Edition (build
> Blackdown-1.4.2-02)
> > Java HotSpot(TM) Client VM (build Blackdown-1.4.2-02, mixed mode)
> >
> > On m'as confirmé que ce VM est le plus compatible avec celui de
> Sun dans le
> > monde des LL.

La JVM ne fais qu'interpréter la language, les JVM libre sont
généralemant de bonne facture.
Ce qui compte c'est la bibliothèque de fonction standard.
Blackdown utilise sa propre version et est la plus compatible.

> Je n'ai pas tout a fait la même chose, je suis en Debian/Stable
>
> lager:rodo rodo$ java -version
> SableVM version 1.11.3
> - compile date and time: 2005-04-12 06:26:04 UTC
> - gcc version: 3.3.5 (Debian 1:3.3.5-8)
> - 'real life brokenness' features enabled
> - signal based exception detection
> - copying garbage collection
> - bidirectional object layout
> - inline-threaded interpreter

Les autres utilisent généralement GNU Classpath, il faut donc que tu
regarde sa version : apt-cache show classpath

la dernière dans sid est la 0.18, sauf erreur. La dernière est la
0.19.

Sa compatibilité est plutôt bonne pour les applications non graphique,
 sinon, pour la compatibilité Swing, bah il reste du travail :)

Good luck.

--
Ludovic Danigo.
                                   (\ /)
                                   (O.o)
                                   (> <)
This is Bunny. Copy Bunny into your signature to help him on his way
to world domination.