[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gtk bloque une install


From Florent Monnier <fmonnier at linux-nantes dot fr dot eu dot org>
Subject gtk bloque une install
Date Fri, 9 Dec 2005 20:48:16 +0100

Bonsoir,

Je cherche à installer une application qui utilise GTK.
Mais le ./configure me dit qu'il ne trouve pas 'gtk+-2.0.pc' et que je devrais 
ajouter le path où le trouver dans la variable d'environnement 
PKG_CONFIG_PATH. Mais je n'ai pas le fichier en question nul part, ni 
dans /usr/lib/pkgconfig/, ni dans /usr/share/pkgconfig/ ni ailleurs dans la 
branche descendant de /usr.

Une solution serait-elle de télécharger les sources de GTK pour récupérer le 
fichier 'gtk+-2.0.pc' et le placer dans /usr/lib/pkgconfig/ ?
Si oui le fichier correspondra-t-il ? Voici ce que j'ai trouvé dans /usr/lib/ 
et qui me semble correspondre à GTK2 : libgtk-linux-fb-2.0.so.0.400.14 et 
libgtk-x11-2.0.so.0.800.

Sur le site de GTK il y a les versions suivantes proposées au téléchargement :
GTK+-2.8 ; GTK+-2.6 ; GTK+-2.4 ; GTK+-1.2

Est-ce que les versions 2.X seront compatible 2.0 ?
(dans l'hypothèse où l'hypothèse de départ d'y récupérer le fichier .pc soit 
vraie)
D'ailleur la version installée sur mon système est-elle une 2.0 ?
Comment le savoir ?
J'ai fait plein de recherches dans rpm-drake sur gtk, libgtk, etc...
J'ai fait une recherche par nom de fichier contenu dans les paquetages sur
'libgtk-x11-2.0.so.0.800' et aucun paquetage ne semble le contenir ni l'autre.

-- 
Merci d'avance de votre aide