Le Petit Journal du Linuxien Novice
© 1999-2007 César Alexanian. Hébergé officiellement chez Linux-France. Serveur principal tournant sous GNU/Linux chez NFrance Conseil
À SUIVRE...
STATS

[ Nedstat ]
Dernière mise à jour : vendredi 30 novembre 2007

[ Page précédente ] | [ Sommaire ] | [ Page suivante ]

La Mandrake 6.0

Juillet 1999.

Après une année de dur labeur, les vacances tant attendues sont enfin là. Mais pas question de rester ignorant de l'actualité linuxienne. Durant notre séjour à Etretrat (en juillet, donc), j'ai acheté le numéro 64 de Login. Sur le cédérom était offerte la distribution Mandrake 6.0 plutôt complète : kernel 2.2.9, KDE et Gnome, The Gimp, etc.

Samedi 21 août 1999.

Dix jours après la fin du monde prévue par l'autre parfumeur, je me jette à l'eau : je fais une mise à jour de la Mandrake 5.2 en 6.0 et je reboote. Tout va bien sauf que... lorsque je lance KDE... le bureau est vierge! Plus rien ne marche! Qu'à cela ne tienne. Puisque je n'ai pas grand'chose de plus sur mon disque, j'utilise les grands moyens : je refais une installation complète de la Mandrake 6.0 en ne reformatant que les partitions / et swap. Ma partition /home avec tous mes fichiers perso restera intacte. Puis je reboote et, ô joie, tout fonctionne à merveille! Je peux basculer de KDE à Gnome voire AfterStep et autres ! C'est génial !

Bon, il ne me reste plus qu'à réinstaller WordPerfect 8.0. Tout se passe bien. Là. Je crée le lien, je lance l'appli... Ça tourne! Je logoutte, j'éteinds. Tout va bien. Le lendemain, je rallume, lance Linux... et horreur! au moment de l'invite graphique proposant le choix du Window Manager voulu, rien ne se passe. Un clic mortel indiquant que l'écran bascule de résolution mais rien. Planté. Je contrôlaltedelle afin de rebooter la bécane, le shutdown se fait et tout s'éteint.

Mardi 24 août 1999.

Après plusieurs tentatives infructueuses, je décide de refaire une installation complète (reformatage, re-attente de l'installation etc.). Puis, puisque je suis un être entêté et que tout fonctionne bien, je refais une installation de WordPerfect 8.0 et... retour quelques lignes plus haut. Bref, ça foire à donf'... Ce sera tout pour ce soir. Voilà. Pour la peine, pendant que j'enregistre Beavis et Butthead se font l'Amérique sur TPS, je me jette dans les bras de Lara Croft afin de finir le niveau Les Iles du ciel. Ce que je fais. Bonne nuit !

Vendredi 27 août 1999.

Je réinstalle la Mandrake 6.0 encore une fois mais, cette fois-ci, je fais l'impasse sur WordPerfect 8.0 jusqu'à plus ample informé. Faut tout de même pas abuser... Ainsi, tout fonctionne à merveille. Je passe sans problème de KDE à Gnome, d'AfterStep à je ne sais plus trop quoi, bref, tout est bon. A part la configuration de ma carte son qui génère un core dumped à chaque tentative. Sndconfig (ou configsnd ou sndsetup, je ne sais plus) a donc du mal à reconnaître ma carte... (ce problème a été résolu en installant la Mandrake 6.1 - voir le chapitre suivant).

Samedi 28 août 1999.

J'ai enfin trouvé mon câble série afin de connecter un modem Olitec Selfmemory 56K à la place de mon Suprafax Modem 336. Et tout se passe mieux qu'avant. Plus besoin de bidouiller avec les panneaux de config ni quoi que ce soit. Il démarre au quart de tour, même sous Linux. De ce côté-là, ça marche !

Mardi 31 août 1999.

Ça y est ! J'ai fait ma première incursion sur l'internet à partir de Linux ! Ô joie ! J'ai donc réussi à paramétrer sans difficulté Kppp et Modem, écrit le script de connexion, défini les trois accès différents que je possède. C'est vraiment super. En plus, Kppp nous donne le montant de la facturation, ce qui est très pratique ! Dommage que je sois toujours frustré du côté WordPerfect (voir en page suivante, au samedi 23 octobre 1999) ainsi que du côté carte son...

Dimanche 12 septembre 1999.

Bon, mon installation a l'air de se comporter normalement depuis la dernière installation. Je commence à installer de nouvelles applications genre IglooFTP Pro aux fins de tests, et d'autres petits utilitaires. Tout se passe à merveille. Je me balade sur l'internet, ça marche du tonnerre de Dieu !

Lundi 13 septembre 1999.

J'allume ma machine. Il est 19 h 15. Je vais aller relever mes boîtes. Je file à la cuisine préparer le dîner... Je reviens voir où en est le démarrage. Horreur ! Le clic mortel est revenu... (voir ci-dessus, au samedi 21 août...). Cela commence à me gonfler sérieusement. Retour case installation. Cette fois-ci, je supprime l'installation de la connexion en mode graphique. Retour à la bonne vieille ligne de commande. Ah, le bon vieux startx ! Et hop, trois quarts d'heure plus tard, me revoilà sous Kde. Tentative de connexion, ça marche. Relève de la boîte... impossible de trouver le serveur de courrier, me dit Kmail... Et l'eau des pâtes qui bout... Extinction des feux, y'en a marre.

Vendredi 17 septembre 1999.

Le calme est revenu. En tant que root, j'ai étendu les permissions de resolv.conf. Le problème venait de là. Lorsque j'ai réinstallé la totale, les permissions avaient sauté et, alors que je me loggais en tant qu'utilisateur, le système n'avait pas accès à /etc/resolv.conf... Tout simplement. Et là, ça va beaucoup mieux ! Mais, côté son, ça ne va toujours pas... Lors du boot, au moment du chargement des pilotes, bash me signale une erreur sur es1701.o. Comment y remédier ? (Problème en partie résolu avec la Mandrake 6.1 (cassini).)

Jeudi 23 septembre 1999.

Je fais le grand plongeon : je vais tenter de compiler mon propre noyau ! Je rassemble trois ou quatre documents traitant du sujet (voir Mes lectures). Je les relis pour la énième fois. Je me logue en tant que root. Et je fonce. cd /usr/src/linux, make xconfig (sous kde) et je paramètre toutes les options. Y, M, N selon... Je sauvegarde ma config'. Puis make dep, make clean, make bzImage (en cinq minutes c'est torché sur mon PII à 350 MHz...), make modules, make modules_install. Tout s'est bien déroulé. Je suis fier de moi ! C'est pas si sorcier ! Je continue. cd /usr/src/linux/arch/i386/boot/ puis cp bzImage /boot/cesarx-2.2.9 (pourquoi pas ?). Puis j'édite /etc/lilo.conf par mc, j'y ajoute ma nouvelle entrée, j'enregistre et quitte. Je lance lilo, qui prend en compte mes nouvelles données... et, fébrile, la sueur au front, les mains tremblantes, mon troisième verre de bourbon ingurgité, je tape reboot. La machine se relance, prompt de lilo, je tape ces (nom que j'ai donné à ma nouvelle entrée)... et ça marche ! Sauf que ça bloque au moment ou ça me dit "Finding modules dependencies". Je contrôle-c, et ça continue. J'arrive au log. Ça a marché ! Je me loggue en tant qu'utilisateur et tape startx. Tout marche ! Mais, encore une fois, j'ai tenté de configurer ma carte son, et ça m'envoie toujours dans le mur (je ne compte plus les bosses...). Parti dans ma lancée, je recompile mon noyau en changeant les paramètres et pilotes de la carte son. Tout se passe bien sauf que... ma carte son continue de refuser de fonctionner. A chaque fois c'est pareil, sndconfig se plante lamentablement et génère un core dumped. (Voir commentaire du vendredi 27 août.) On verra plus tard. Au moins, j'ai appris à compiler mon noyau et je n'ai plus peur.

Remonter

Site réalisé sous Gnu-Linux en PHP mis en forme avec Quanta et mis en ligne grâce à gFTP sous la Mandrake 9.1